Author Topic: digital dash problems  (Read 23864 times)

wee epy

  • Newbie
  • *
  • Posts: 1
    • View Profile
digital dash problems
« on: April 16, 2010, 03:31:49 PM »
Hi Guys, Any got any advice about digitaL DASHES FOR MY 2006 GRISO.
i love the looks and performance of this machine and have covered 16000 mls since owning the bike from new.
however in the last week, the dash has gone awal. i have tried gentle heat and electrical spray to no avail.
i bought the machine in the belief that it would last 100,000mls--- not if the electrics are iffy!
any thoughts?
       cheers wee epy

GuzziHero

  • Newbie
  • *
  • Posts: 4
    • View Profile
    • Email
Re: digital dash problems
« Reply #1 on: April 25, 2010, 11:39:07 PM »
I'm guessing you've had the steaming problem in the clocks? 

A guy on Guzzitech has this problem, and has been told his circuitry has most likely corroded.  When you get a replacement you need to seal/vent it better.  They put up a guide here: http://forum.guzzitech.com/forum/download.html?id=969 (document format download).

Griso Guy

  • Newbie
  • *
  • Posts: 1
    • View Profile
    • Email
Re: digital dash problems
« Reply #2 on: July 28, 2010, 03:39:14 PM »
Having a problem with the dash, but mine ask's for code which I never switched from the factory.  Freaking thing won't allow me to start it and go riding.  When it does fire it runs great, but I can't trust it & the importer has refused to help. They even stated that there are no other dash problems with Griso's, I located 6 plus mine, 7.  Guzzi doesn't want to help recall the bikes with an odometer reading of 10,365 miles on it.  I'm finished with buying another Guzzi.  I'll try a BMW next unless I hear bad things about them.  I hate to leave Guzzi, since I had a couple & was going to buy a new Norge.  Not now.
I think we need to make a natonal or even a global stink about it.